Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Vtag / Emu not working

Hi All,

I got an RFIDler from DefCon 22.  Like all of you here, I think its a cool device and I personally have been waiting for one for sometime now. 
Proxmark is just darn expensive. 

I have been playing with the device since the 1st day I got it. 
The basic features work like autotag, setting tag type, reader, config, sniffer, etc.
However when I use vtag and emulation related commands (set vtag, copy) the RFIDler seems to reset and become disconnected. 
I lose serial connectivity and unable to reconnect unless I unplug it. 

I already re-flashed the device to the latest firmware as of 8/12 which is 0057-beta but still the same results.  

Is this a hardware or software issue? Any fix?

On an unrelated question, is there any documentation on the API mode?

Any help is appreciated. 

Thanks,
t1nkerH3ad

Tagged:

Comments

  • I don't know the fix but I just wanted to comment to say I'm having the same issue.
  • Hi Guys, I am having this exact same issue :(
  • Looks like its a software issue. Probably a bug on the most recent commit.
    Rolled back to 0054-beta firmware (committed last 0713) and vtag, copy and emu works without crashing the device.
    Hopefully Adam can provide the fix with the updates merged.
  • edited August 2014
    I will take a look at the crashing / emu issue - can you confirm exact steps as I'm emulating with no problem so it may be tag type specific.

    As far as docco for the API mode goes, take a look at the python wrapper - the code should be commented enough to explain what's going on.

    I agree that documentation is probably one of the main issues - we need to start populating the Wiki!
  • Hi Adam,

    On 0057-beta, the crash happens when setting vtag to fsk1raw or fsk2raw.
    Basically, I did the following:
    - autotag
    - set tag fsk1raw or fsk2raw
    - uid
    - set vtag fsk1raw or fsk2raw
    - vtag
    - if vtag doesn't have uid info, I ran autotag again
    - if I get a uid, I issue copy command and vtag to confirm it has copied the info
    - if successful, then I do emulator bg

    I've confirmed that if I use set vtag to q5, it doesn't crash.
    And doing copy and running emulator [bg] also doesn't cause it crash.
    However, when doing that, I expected the emulator led to light up, but it doesn't.
    Also while on emulator mode, a reader is not able to recognize anything from the device so it means its not sending anything at all.

    If I'm doing anything wrong, can you list the correct steps to do emulation?

    Thanks!


  • On version 0114-beta.  Unable to set the vtag type.  Any type I choose causes the board to reboot.

    Any assistance would be greatly appreciated!
  • Hi,

    I've just tested this on my dev board with 114-beta in both production and debug versions and it works fine for all but the raw modes which do indeed cause a reboot. I'll take a look.

    In the meantime, if you need to emulate a raw tag, just set the vtag to either q5 or t55x7 and the main tag type to the one you want to emulate, then ENCODE or COPY to the vtag. When you run the emulator, it will emulate a q5/t55x7 emulating the original target.

    If you can't set vtag to q5 or t55x7 then we'll need to look into it further, but right now I can't reproduce that problem. Does anyone else see this?

    cheers,
    Adam
  • Thanks for the quick reply, Adam!

    Using the Q5 for the VTAG does work and the emulation is using one of the raw formats that I needed.  What are the drawbacks to the VTAG not using the same type as the physical tags?

    Let me know about the reboot bug.  I hope that gets cleared-up.

    Thanks again!

    Adam
  • There is no difference from the emulation side and in fact it's an advantage as it confirms that writing that VTAG to a Q5 or T55X7 should then also work as a standalone tag.
  • I have the same problem.  The tag type of the card I'm attempting to copy is askraw.  When I use the copy command it freezes up my connection and I have to kill the putty window and reconnect to the RFIDler. 
    I updated to the latest firmware but no change. 

    Any fix for this?
  • Can you post the exact sequence and tag format so I can see if I can reproduce it?
  • Actually setting the vtag to q5 worked for me as well. 
Sign In or Register to comment.