Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

mphidflash working on Windows?

I have used mphidflash with the RFIDler before, but no version is currently working for me.

Sometimes the mphidflash connects to the board, sends the firmware, but it just ends up throwing "mphidflash Error: Verify failed".
Other times mphidflash just hangs after displaying "USB HID device found".

Is mphidflash working for anyone else?

I also downloaded the Microchip tools accompanying App Note 1388 - http://www.microchip.com/wwwAppNotes/AppNotes.aspx?appnote=en554836
But the Windows software does not support the HID bootloader. (It appears to support serial, virtual serial port over USB or ethernet bootloaders only.)

Comments

  • I've had no joy trying to update my Rfidler with Mphidflash either. Tried win 8.1 & 7 pro with same result.
    My error is however very different. I keep getting:  Flash Error: Unrecognized or invalid hex file syntax.
    Tried various compatibility settings and have now given up. My board is now in-op as the flash has been erased and is waiting on firmware upgrade.  Tried the HID bootloader as well, same deal.
    I may have to use a linux distrubution or something with cygwin... not a lot of time in my schedule to play around as I'd hoped. 
  • edited March 2015
    Worked for me on Windows 8.1 with mphidflash Version 1.6 (from google code site)
    1) set your device into bootloader mode (keep button "bootloader" pressed while connecting the USB cable
    2) Create a clean folder on your C: drive and place the files mphidflash.....exe and the latest firmware from Github (RFIDler.X.production.hex)
    3) Now open a "cmd" window. Enter your newly created folder and type "mphidflash.exe" without any syntax (I had previously renamed the long file mphidflash.1.6....exe into simply "mphidflash.exe"
    If the software can see your rfidler board, you should now see on the screen following wording "USB HID device found: 503808 bytes free, Device family: PIC32"
    Make sure you have the file "RFIDler.X.production.hex" in the same folder as the executable mphidflash.exe

    5) Now type following: "mphidflash -write RFIDler.X.production.hex -reset" without quotes
    ... and you should now see some message stating "ERASING........", Writing.................. and finally "Verifying............". There will be lots of "............." so don't worry. It takes less than one minute.

    with the software "putty" you will be able to verify that the new firmware version was stored. Run "Putty.exe", adjust to serial mode, enter the correct COM port (mine was COM 4) and adjust the speed to 115200 baud. If everything works (driver installed, etc), your board will welcome you with the "RFIDler>" after few times pressing the "ENTER" key.
    You may type "Version" to see your firmware version.
    My board came today with 0062-beta and is now after the update on 0108-beta.

    Good luck and happy experimenting
  • edited March 2015

  • Just so no-one gets confused - the latest firmware version loaded today into https://github.com/ApertureLabsLtd/RFIDler/blob/master/firmware/Pic32/RFIDler.X/dist/default/production/RFIDler.X.production.hex is version 0114-beta. There's no need to go through the full build process.

    You can use "git pull" to grab the updated version, the .hex file does not have to be in the same directory as mphidflash, you don't have to rebuild mphidflash for the supported versions. The command I used was <br><br>sudo ./mphidflash-1.6-linux-64 -r -w RFIDler/firmware/Pic32/RFIDler.X/dist/default/production/RFIDler.X.production.hex
    (Your directory structure may vary!)
  • A couple of notes ..

    1. Mphidflash is pretty reliable when the Rfidler is directly connected to my PC, usually works if connected via 1 unpowered hub, and never works if I make a mistake & leave it connected to an unpowered hub further away.

    2. I hope to include a GUI tool for programming the Rfidler in my Windows Rfidler Monitor program. Currently the Monitor shows stuff such as which COM ports are assigned to Rfidlers, Rfidler serial numbers, which USB ports/hubs are connected to Rfidlers.
    https://github.com/ApertureLabsLtd/RFIDler/blob/master/windows driver/rfidlermonitor.exe
Sign In or Register to comment.