Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Any minicom tutorials out there ?

edited June 2016 in RFIDler General
When i go to copy a card the minicom popup jumps up and says "cannot open dev/ttyAMC0!"

Can some one help me please, ive spend 2 days getting to this point and ive learnt so much from all of you but really want to copy/clone.emu a card.And i do realize this is not a class on computing so thanks for any help guys.
The command lines im using in minicom are:

1,Autotag
2,Then i notice im getting an askraw out put so i set the next line to "Set tag ASKRAW" it says OK
3,Then i ask it to copy tag and the minicom popup appears and the whole thing freezes for a few seconds, i cant even type any keys so ive done something wrong and was wondering if anyone had experienced this ? Are there some permissions ive missed along the way

Also i haven't been able to set the blacklist rules, i haven't managed how to add the read me from the Linux Support folder to the etc/udev/rules.d folder yet, Ive tried dragging and dropping and ive tried on the command line too but i get "command not found errors:

root@mrrobot-Compaq-610:/etc/udev/rules.d# # place this file in /etc/udev/rules.d and run 'sudo udevadm control --reload-rules'
root@mrrobot-Compaq-610:/etc/udev/rules.d# ACTION!="add|change", GOTO="mm_usb_device_blacklist_end"
root@mrrobot-Compaq-610:/etc/udev/rules.d# # bootloader mode (microchip ID)
root@mrrobot-Compaq-610:/etc/udev/rules.d# ATTRS{idVendor}=="04d8" ATTRS{idProduct}=="003c" MODE:="0666" SYMLINK+="RFIDlerBL"
ATTRS{idVendor}==04d8: command not found
root@mrrobot-Compaq-610:/etc/udev/rules.d# SUBSYSTEM!="tty", GOTO="mm_ignore"
SUBSYSTEM!=tty,: command not found
 root@mrrobot-Compaq-610:/etc/udev/rules.d# # openmoko issued id for rfidler-lf
root@mrrobot-Compaq-610:/etc/udev/rules.d# # http://wiki.openmoko.org/wiki/USB_Product_IDs
root@mrrobot-Compaq-610:/etc/udev/rules.d# ATTRS{idVendor}=="1d50" ATTRS{idProduct}=="6098" MODE:="0666" SYMLINK+="RFIDler"
ATTRS{idVendor}==1d50: command not found
root@mrrobot-Compaq-610:/etc/udev/rules.d# LABEL="mm_ignore"
root@mrrobot-Compaq-610:/etc/udev/rules.d# ATTRS{idVendor}=="1d50" ATTRS{idProduct}=="6098", ENV{ID_MM_DEVICE_IGNORE}="1"
ATTRS{idVendor}==1d50: command not found



Comments

  • Just because you get output from one of the *RAW autotag types, doesn't mean it's UID, or even that you're getting consistent data. Just means that the raw format is picking up something it thinks may be data. Try running autotag multiple times, with the tag at different distances away from the coil, see if the output is the same or if you pickup a different tag type. You'll have much better luck if you can identify the tag as UNIQUE, T55X7, HID26, etc. and unless you've set the modulation (data bits, sync bits, pots, etc), you probably shouldn't be trying to get data from the *RAW modes. If you're not sure what the tag type is, look at Plotting on the GitHub wiki.

    I've noticed that sometimes the RFIDler will hang when you ask it to do something while there is no tag near the coil. Make sure your firmware is updated, and when it hangs, try putting a tag nearby. There is also documented trouble with smaller tags throughout the forum.

    Usually when I see "cannot open /dev/ttyACM0", it's because the USB cable has unplugged, or the device has reset. Make sure the firmware is up to date, and that you have a decent USB cable. If you're running the device with sudo/root, there won't be a permissions problem.
  • edited June 2016
    So how do i know what sort of tag i have if i haven't set up plot graphs just jet, cant i just do i autotag to detect what type of tag i have ?

    Im geting ASK, FSK1 FSK2 from my readings and its not always consistent, sometimes i get FSK sometimes i dont but i always get ASK. and your right the height of the card makes a difference.

    When running putty are there any Pairity or Flow Control setting that need to be changed ?

    I have pairity set to None and flow control on XONXOFF although i will try experimenting with these setting to see if they make a difference as i dont know what else to do

    Ill have to set up plots soon but one program at a time as this is all new to me.
    Thanks
  • There shouldn't be anything you need to setup with PuTTY or Minicom (re: parity and flow control).

    I'm not sure how it works on Windows (I've only been using Linux), but the setup for plotting should be very easy. Read the documentation here: https://github.com/ApertureLabsLtd/RFIDler

    You'll essentially want to clone the GitHub repository, and run python/setup.py. You shouldn't need any additional resources in Linux to perform plotting, and it is definitely the best way to figure out what type of card you have if AUTOTAG isn't finding it. If you know what the tag should be (if it has some writing on it, like HID or UNIQUE), you can set it to the proper tag (NOT *RAW) and type READER on your RFIDler prompt. If you get a consistent UID read, you should be good to go.

    The *RAW types are not tags, but raw output. You'll have a very difficult time trying to copy a tag from one of these (if at all), and that will require using plotting to figure out the exact type of demodulation needed to read the card.

    A couple of things I want to point out: if your tag is 13.56 MHz (you'll get an idea from plotting), you won't be able to read it with the RFIDler, the hardware is just not made for it. Second, you can't just write to any card, you have to writable cards to clone from one to another, and they have to be compatible with each other.

    If you want my advice, I'd start with a firmware update, and get familiar with plotting before attempting to copy any tags. It will get you much more familiar with the technology you're working with, and you'll have an easier time trying to troubleshoot tags in the future.

    Good luck, and hope this is helpful for you.
    eth3real
  • Thanks so much, for someone like me who only has a basic understanding of how linux works and is only new to micro controllers any help i get from this forum helps me so much, ive learned so much in just one week from this forum and your advice is not lost.

    Its no ones fault but mine but when i downloaded the RFIDler folder from github i had no idea what to do first, there was no real clear order of things on what i need to get the board to operate, it just like here you go here are the tools heres a bit of info now go work it out,( it only seems this way to me mind you cause everything is new to me, i was using MPLABSx to read cards till i realized ive stared on step 4 instead of step 2 for example. Its was 2 days later that i realized minicom is the CLI interface that talks with the board.

    Ive decided to forget everything i know and start again and one day perhaps make a clearer set up guide for people with basic understanding so they too can perhaps get involved and help grow our community.


  • edited June 2016
    So how do i run that python/setup.py file ? im back on my linux system (ubuntu) and have started from a different perspective today and on a fairly new machine

    How do i run it ? it opens up by default with gedit and dont see any run commands when right click the file. Are there any programs or plug ins ive missed as this is a fairly fresh install Ver 16.04

    Oh btw i have Eric Python and Bpython from the ububtu software center and i can open those file but not sure how i run them or what to do with them, ive only ran python a bunch of times and kinda lost this morning ?

    So when opening it up in EricPython and i try running it it asks for a Command Line, working directory and Environment ? Am i on the right path to running this script at all ?
  • am i running the python/setup.py files in terminal while logged in to python like this :

    mrrobot@mrrobot-Compaq-610:~/Downloads/Python-3.5.1$

    then add the python files into my terminal ? if yes then which one do i run first as there are a few files in the python folder in the rfidelr master ?
  • Brazen46, Google is your friend. I think a lot of people are willing to give you all of the instructions, but lack the time, and these things are already written up if you search for them.

    Start here for rfidler installation and firmware update:

    After installation and firmware update, the instructions here will help you with plotting:
    Yes, this is still the best and definitive way to figure out what tag you have.

    AUTOTAG will only work when your tag is at the right height, and still may take several attempts. If the tag is very small, it may not work at all. Having your firmware updated is also essential, since there are bugs fixed, as well as more tag types available.

    If you think your tag is HID26, try 'SET TAG HID26' and then 'READER', and hold your tag at different heights. If you get a series of good reads, that's likely the type of tag you have. Figure out what height works best, and then try 'COPY' several times with the tag at the right height. It doesn't always work on the first shot, keep trying.

    If you get a successful copy, use 'VTAG' to see what was copied to memory. You won't be able to clone without a writable tag, and you'll need to know the type for that tag as well (it will be different than your original tag). The commands are 'CONVERT <writable tag type>' and 'CLONE'.

    Tags of all types, read-only and writable, can be found on eBay for very small costs.

    Keep trying your best, this will get easier over time. Read as much as you can, and make sure you've done your own research before asking questions, since most issues have already been documented and resolved. Good luck!
Sign In or Register to comment.